Payment Processing Issues

Incident Report for Tabby

Resolved

Dear Clients,

The payment processing issue reported in KSA has been resolved. Normal service resumed at 13:30 UTC.

We thank you for your patience and cooperation. Should you encounter any further issues, feel free to reach out to our support team.
Posted Feb 24, 2026 - 13:44 UTC

Identified

Dear Clients,

The issue affecting payment processing in KSA has been identified. The disruptions began at 13:20 UTC.

We are working on a fix and will restore normal service as soon as possible.
Thank you for your patience.
Posted Feb 24, 2026 - 13:43 UTC
This incident affected: Checkout, Payment Management API, Customer Portal, and Customer Mobile App.