The scheduled maintenance has been moved to a new date with a shorter window: 2025-09-19, 00:00 UTC to 00:10 UTC.
The expected downtime is around 5 minutes, so there is no need to turn off Tabby services — they will recover automatically once the maintenance is complete. During this time, services in Saudi Arabia, the United Arab Emirates, and Kuwait may operate with limited functionality.
Posted Sep 15, 2025 - 14:30 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 15, 2025 - 14:28 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 15, 2025 - 14:25 UTC
Scheduled
Dear Clients,
The scheduled maintenance has been moved to a new date with a shorter window: 2025-09-19, 00:00 UTC to 00:10 UTC.
The expected downtime is around 5 minutes, so there is no need to turn off Tabby services — they will recover automatically once the maintenance is complete. During this time, services in Saudi Arabia, the United Arab Emirates, and Kuwait may operate with limited functionality.
Posted Sep 15, 2025 - 00:00 UTC
This scheduled maintenance affects: Checkout, Payment Management API, Customer Portal, Merchant Portal, Merchant Reports, Merchant Application, Customer Mobile App, and Main website.