Issues with Checkout Process and Payment in United Arab Emirates

Incident Report for Tabby

Resolved

It has now been resolved and everything is working correctly.
Our apologies for the inconvenience.
Posted Apr 13, 2026 - 09:23 UTC

Investigating

Dear Clients,

We are investigating intermittent payment processing issues reported in UAE starting at 2026-04-13 08:25:00 UTC. Customers may experience difficulties completing transactions during this time.

Our team is actively working to resolve the issue as quickly as possible.
We appreciate your patience and understanding.
Posted Apr 13, 2026 - 09:03 UTC
This incident affected: Checkout and Payment Management API.