The incident has been resolved. We apologize for any inconvenience or concern this may have caused.
Posted Jul 01, 2026 - 14:40 UTC
Monitoring
The fix has been implemented. And issue resolved from 2026-07-01 14:27:23 UTC. We are monitoring the situation
Posted Jul 01, 2026 - 14:34 UTC
Identified
Our team is actively working to resolve the issue as quickly as possible. Thank you for your understanding and patience. We will provide an update by 2026-07-01 14:45:23 UTC.
Posted Jul 01, 2026 - 14:25 UTC
Investigating
Dear Clients,
We are currently investigating reports of issues with our checkout process, in KSA starting from 2026-07-01 13:47:00 UTC. During this period, customers may experience difficulties completing their purchases.
Our team is actively working to identify the root cause and resolve the issue as quickly as possible. Thank you for your understanding and patience. We will provide an update by 2026-07-01 14:05:23 UTC.