We have implemented a fix to address the issue, and the login process is now working correctly. We are continuing to monitor the situation to ensure full stability.
Posted Nov 18, 2025 - 14:02 UTC
Identified
Dear Merchants,
We are currently investigating reports of access issues with the Merchant Dashboard starting from 11:48 UTC. Some users may experience difficulties logging in or using certain dashboard features.
We want to note that this incident is related to a global disruption at our third-party provider, Cloudflare(https://www.cloudflarestatus.com/incidents/8gmgl950y3h7), which is affecting multiple online services worldwide. Our systems remain operational, but due to this external issue, some requests may fail or behave inconsistently.
Our teams are actively monitoring the situation and working closely with Cloudflare to ensure full restoration as soon as possible. We sincerely apologize for the inconvenience and appreciate your patience during this global outage.
We will provide updates as soon as new information becomes available.
Posted Nov 18, 2025 - 13:31 UTC
Investigating
Dear Merchants,
We are currently investigating reports of access issues with the Merchant Dashboard, starting from 11:48 UTC. Some users may experience difficulties logging in or using dashboard features.
Our team is working diligently to identify and resolve the issue promptly. We apologize for any inconvenience and appreciate your patience. We will provide an update ASAP.
Posted Nov 18, 2025 - 12:47 UTC
This incident affected: Merchant Portal and Merchant Application.