Issues with Checkout Process

Incident Report for Tabby

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 11:22 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2026 - 11:19 UTC

Identified

Dear Clients,

We have identified the cause of the issues affecting our checkout process in UAE. These issues started at 09:54 UTC and are currently being addressed.

Our team is working diligently to implement a solution and restore full service.
Thank you for your patience during this time. We will share further updates ASAP.
Posted Apr 14, 2026 - 10:14 UTC
This incident affected: Checkout.