Intermittent failure while submitting the transactions to Mastercard payment gateway services-Saudi Arabia

Incident Report for Tabby

Resolved

This incident has been resolved.
Posted Jun 20, 2025 - 18:13 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 20, 2025 - 15:41 UTC

Identified

A service degradation has been identified for Mastercard Gateway in the Kingdom of Saudi Arabia starting from 13:34 UTC, 20 June 2025.

Mastercard team is working to resolve the issue on priority.

Customers may experience intermittent latency and error while submitting transactions to the Mastercard Payment Gateway service - Saudi Arabia.

We will post further updates from Mastercard till resolution of the issue.

Thank you for your patience and continued support.
Posted Jun 20, 2025 - 15:39 UTC
This incident affected: Checkout and Customer Mobile App.