Intermittent transactions failure detected from Emirates NBD Bank issuer

Incident Report for Tabby

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 13:09 UTC

Investigating

We are currently investigating this issue.
Posted Jun 23, 2025 - 11:59 UTC