Payment Processing Issues

Incident Report for Tabby

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 13:39 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 23, 2025 - 13:23 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 23, 2025 - 12:53 UTC

Investigating

Dear Clients,

We are investigating intermittent payment processing issues reported in all starting at 11:20 UTC. Customers may experience difficulties completing transactions during this time.

Our team is actively working to resolve the issue as quickly as possible.
We appreciate your patience and understanding. Updates will be provided in 12:40 pm UTC.
Posted Jun 23, 2025 - 12:19 UTC
This incident affected: Checkout, Payment Management API, Customer Portal, Merchant Portal, Merchant Reports, Merchant Application, Customer Mobile App, and Main website.