The payment processing issue reported in Saudi Arabia has been resolved. Normal service resumed at 23:35 UTC.
We thank you for your patience and cooperation. Should you encounter any further issues, feel free to reach out to our support team.
Posted 27 days ago. Apr 18, 2025 - 23:57 UTC
Monitoring
Dear Clients,
We have implemented a solution to address the payment processing issue affecting Saudi Arabia.
We are monitoring the system to ensure everything is operating as expected. Thank you for your understanding. Updates will be provided if necessary.
Posted 27 days ago. Apr 18, 2025 - 23:47 UTC
Identified
Dear Clients,
The issue affecting payment processing in Saudi Arabia has been identified. The disruptions began at 2025-04-17 23:17:00 UTC.
We are working on a fix and will restore normal service as soon as possible. Thank you for your patience. Further updates will be shared by 2025-04-17 23:54:10 UTC.
Posted 27 days ago. Apr 18, 2025 - 23:34 UTC
This incident affected: Checkout, Customer Portal, Customer Mobile App, and Main website.