Issues with Checkout Process

Incident Report for Tabby

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 16:43 UTC

Monitoring

The fix has been implemented and we are monitoring the result.
Posted Oct 29, 2025 - 16:33 UTC

Identified

Dear Clients,

We have identified the cause of the issues affecting our checkout process. These issues started at 15:45 UTC and are currently being addressed.

Our team is working diligently to implement a solution and restore full service.
Thank you for your patience during this time. We will share further updates ASAP.
Posted Oct 29, 2025 - 16:15 UTC
This incident affected: Checkout.